Colour artefacts or breakup using ACES

Tags: #<Tag:0x00007f0fdf1fc818> #<Tag:0x00007f0fdf1fc610> #<Tag:0x00007f0fdf1fc368> #<Tag:0x00007f0fdf1fc228>

Is it present with the RED LUTs? Might just be a limit of the camera…?

Don’t think so

I’ve imported the same file in a YRGB project, IPP2 RedWideGamutRGB + Log3G10, and even though something similar does happen when I apply a Rec709 LUT or the ColorSpaceTransform, it’s not present at the origin… I can easily manage it without using LUTs, working “behind” them or automatic transforms as well.

So far the “fix” has been setting WB to 1700 and then bringing back the correct WB with grading tools, but that feels wrong. And I’m prettty sure client will ask why the Non-Graded Archival Master is so off-balance in a few shots…

I’ve worked on a film shot on F55 that was HEAVY on neons, red, blue and green lights, all king of colorful and bright footage, without any artifacts whatsoever (apart from the ones easily fixed with the DCTL)

Are you using ACES in the project “Color Management” panel? Or, AcesTransform?

If you manage you project in AcesTransform you can try the following: use a ColorspaceTransform to go from IPP2 to Arri Wide Gamut and use the ARRI IDT. That “might” help.

Note that the best way I foung to apply the aces_fixHighlight.dctl file is to sandwhich it between the IDT and ACES Ap-0. You can then go from Ap-0 to ACEScct for grading.

Cheers

I’m using the Color Management Panel in this project. In this case, I usually apply the FixHighlight DCTL as an Input DCTL in the file! Since the debayer is straight to AP0/Linear, I think it makes sense, right?

I’ve tested your tip, and it works very well!

I think the client will prefer I don’t do the ACES Color Management with the OFX, since they’ll receive the project and they were kind of specific about this workflow

I’ll check with them if it’s an option…

Made a few new tests, all using ACES in the Color Management panel:

If I use the Gamut Limiter OFX and set it from AP1/cct to a less broad gamut, it seems to work very well to solve this issue.

Arri Wide Gamut fixes it in the situation I set the example to, but in another situation with a car light it’s still a little bit problematic:
02%20PM

If I set the limiter it to Rec709 it solves the issue, but I’m… limiting ACEScct to Rec709, which feels crazy.
13%20PM

(I’m showing it dessaturated because it’s easier to see the issue, I think)

Are you always grading in AP0? Or, are you grading in ACEScct? That might just be the problem…

Personaly, I feel the that the ACEStransform workflow is easier as ou can manage only the camera footage thru ACES. You can group your cameras together and use the Pre group and post group for IDTs and ODTs,

This workflow doesn’t force everything thru ACES before the grade. AKA editing effects and titles will look correct (I’m still on 15 so don,t know if that’s still an issue in 16). Basically makes resolve behave like NUKE. Let’s say you want to pull a nice key. Just add a corrector and go from ACEScct to 709, pull you key and just link the nodes thru alpha. It also enables you ability to work in other color spaces for OFX purposes.

I’m grading in Acescct!
So, in this project I have to deliver an Archival Master fully in ACES ap0 (hence, without the ODT), so everything would need to go through the pipeline

I really like working with the Aces Transform ofx and feel safer with it, but I’ve never encountered anything I had to fix outside of ACES before, specially with a camera like a Red Helium, so I figure I’d follow the client’s guidelines and I’d be fine with it

All digital cinema cameras can have “holes” with very saturated lighting (such has cheap LEDs etc…). So you might of just found one.

If you produce a NGAM and manipulate before going to ACES then the workflow is good and the footage will always replicate correctly. ;o)

Indeed, maybe! Looks ugly as hell though :joy:

You right about the NGAM! I’ll see if the client is bothered by me changing to this workflow. It’s not like I lost my day’s work as soon as I keep in Cct

Thanks

I think you’re client we’ll be happy that you can fix de problem correctly! :grinning:

It’s not really changing anyhting. ACES data will be the same in the end.

1 Like

I just used a similar fix. ACEScct with Sony footage. IDT set to proper camera. ODT to REC709. I had this hilite issue (have been frustrated with this for a while) with 1 shot. Just added a CST on the first node and converted from Timeline to Arri Log C and the issue completely went away!

2 Likes

Hi,

I’ve read the explanations of the issue. @sdyer Have you made some graphs since for the explanation?

Thanks!

Hi @VincentC,

There is a whole group working on this topic here: https://community.acescentral.com/c/aces-development-acesnext/vwg-aces-gamut-mapping-working-group/80

Cheers,

Thomas

Hi Thomas,

thanks I will take a look at it.

Cheers

hi scot,
thanks for your articals here, they helped me alot to understand the ACES in better way.
i am in intensive reading about Acses since few days. i have the issu with the Black Magic Camera Pocket 4k/6k.
my issu is:
your matrix works well with the blue lights/ as the build davinci in LMT neon Suppression.
my issu is witht othe colors spicely the Red color. is there a way to get red of the cliped Reds with out using the Gamut maping?? like using a kind of DCTL?
this ithe main issu why i cant use aces in my workflow. and i love to work in aces as it looks more promising than other color spaces out there.
cheers

1 Like

Hi Guys,

Thank you for the tools you developed they are super useful. I am currently working on a project that shot cinema DNGs with the Ursa Mini Pro (BMD 4.6K Film Gen 3). Footage has artefacts in the cheap LEDS as expected but also in the high luminance parts of the images (candle lights and light reflections). I have applied LMT.Academy.FixHighlight.dctl directly onto the clip as per Scott Dyers instructions and I do see a change in the blue LED’S but it does not remove the artefacts completely. I have also tried to apply the dctl in the colour tab with two transforms, ACES cct to ACES > LMT.Academy.FixHighlight.dctl > ACES to ACES cct and It has given me the same results.

I am using ACES cct in Davinci 16.2 - IDT set to no Input - ODT Rec709

I have uploaded some of the dngs here https://www.dropbox.com/t/oTXlkIAB8gHMQIIe
I don’t seem to get these artefacts when working in Davinci YRGB managed.

Ideally I would like to work in aces as the project has multiple types of cameras and I think ACES is the way forward for this.

Thanks a ton in advance !

1 Like

Hi Jose! Thanks for posting this example clip.

I loaded it into Resolve and tried to replicate the screenshot that you shared here, but I can’t seem to get the same results. I’m not an expert in Resolve, so maybe I’m missing something.

A couple of questions:

  • Are you using default debayer settings?
  • Are you doing any scaling in your timeline?
  • The pattern around the highlights almost looks like an image filtering artifact…

Here are a couple of screenshots of the behavior I’m seeing.
screenshot_2020-06-17_13-39-19
Colorspace settings


Debayer settings

Image

You’re welcome to try out the GamutCompress DCTL, but with those artifacts I’m not sure how much it will resolve the issue.

I did three comparisons:

  • Color Science = ACES, ODT = Rec. 709
  • Color Science = ACES, using “LMT Neon Suppression” CLF, ODT = Rec. 709
  • Davinci YRGB Color Managed, Input Color Space = Blackmagic Design 4.6K Film Gen 3, Output Color Space = Rec. 709 Gamma 2.2

I’m far from a regular Resolve user, especially for non-ACES projects, so without a viewing LUT for BMD 4.6K Film Gen 3, I don’t know how you would properly render and view this image in regular Davinci YRGB mode.

Though it’s still not perfect, I prefer the LMT version.

Color Science = ACES, ODT = Rec. 709

Color Science = ACES, using “LMT Neon Suppression” CLF, ODT = Rec. 709

Davinci YRGB Color Managed, Input Color Space = Blackmagic Design 4.6K Film Gen 3, Output Color Space = Rec. 709 Gamma 2.2

2 Likes

Hey @Jed Smith,

I have indeed been using the default debayer (same as your ref still), I have changed it to Full Res in the Camera Raw settings under the project settings panel and it significantly changed the artefacts for the better (for some reason Resolve sets this to Quarter Res?). I have set my project settings to match the resolution of the footage and again artefacts got better again specially around the candle light (It was set to 4096x2160). I think I agree with @sdyer and the LMT Neon Suppression does the trick with delivering better uniform color to the LEDS. Thank you for the GamutCompressor, I have played with it and feels like a very useful tool.

You guys are legends!! many praises

I switched to the Sony FX9 earlier this year and have been running into this problem more than with any other camera. The camera can really resolve deep deep blues and reds. FX9 really fills up the whole S-Gamut3 color space. This shot of the guitar is the most extreme I have ever seen. Every highlight on the guitar strings was just bonkers.

I am glad I found this thread. In Resolve choosing Neon Suppression is totally enough to fix it.

1 Like