Aces in After Effects - scopes are... incorrect

I just started to almost understand how ACES in Ae can work for post production for video and compositing, but there’s one really big blind spot and that’s the lumetri scopes. in order for Aces to work in Ae, you have to disable view->display color management. but the scopes don’t know that… they show you the signal as if display CM is on.

talking specifically for a pipeline when dealing with video sources from different cameras to composite together with flexibility to output to multiple transforms (scene referred, display referred, Aces etc) . setting my project to Acescg workspace, disabling CM for each footage, and OCIO for each footage from its profile to Acescg.

this is Acescg workspace, view-display color management off

this is rec709 workspace - view-display color management on (the correct scopes)

as you can see - the image is the same, the scopes are not. if this is the case when working in Acescg workspace in Ae, I don’t see how you can do compositing and color corrections when the scopes are showing you a different signal than the one you are viewing…

so Ae users, how do you work around that?

I just replied to your other thread with a workflow suggestion. I don’t think you have the scopes problem if you set it up like that. Let me know how it goes! :slight_smile:

1 Like

thanks @Shebbe oh what a ride… :slight_smile: I eventually followed @i_go_by_zak (thanks Zak!) workflow for using Ae’s display color management with a gamma fix adj and now the world makes sense again :slight_smile:

see this setup, I get the LOG conversion I wanted and work in linear mode and using Ae’s display color management so lumetri shows the right signal. you do need to preserve RGB to all the media, and add a adj layer of gamma fix. still much better then the ACESCG workspace confusion. see here
project: 32bit, linearize working space, rec709
each footage item: interpret footage, preserve RGB
view-display color management - ON
Adj layer on top of the comp with color profile converter set to rec709 input and output, linearize output profile
all the rest is the same- OCIO on each footage from its color profile to AcesCG.
render as normal (no need to preserve RGB)

as for you setup - will answer you in the post :slight_smile:

Your setup is also a totally valid way of approaching it but there are some errors.

I see you are using ACES only to remove the gamma which is incorrect.
ACEScg is a colorspace not just a linear transfer function.

You are treating your Arri Wide Gamut footage and your Rec.709 2.4 gamma footage as ACEScg now and converting from that colorspace back to Arri Wide Gamut LogC v3 EI800. The result was that the log curve was correct but the colors weren’t.

You have to transform both the colorspace and gamma on all assets going in to ACEScg not just the gamma.

1 Like

I was trying to follow’s zak’s path where he offered a hybrid that will make things easier, and I didn’t notice any difference.

so I did a test. I rendered my rec 709 working space, linear, Aces for just transfer functions comp vs Acescg working space linear with the full workflow where you reserve rgb in the export options, then I placed the renders back in Ae one over the other with scopes open and no color management and the result was exactly the same.

see for yourself here’s the same project but with a project setup in acescg. compare it to the project I posted and see what you make of it.

if there is a difference if that is the case, and I must use Acescg when I linearize the working space, and not use view-display color management and be blinded because my scopes are not correct, and all that tick preserve RGB at the end - this seems to me that acescg workspace+linear is a disaster workflow.

Your drive link isn’t set to people with link can view. But I know what a setup looks like with ACEScg as the project workingspace. This is indeed not ideal at all and also not required luckily.

Your earlier example of working in rec.709 but linearized does work it was just that you were only removing the gamma of your sources and not converting the colorspaces to ACEScg. Then after the linear part and doing your composite you were converting the ACEScg colorspace to Arri Wide Gamut LogC. So your colors weren’t the same as input anymore.

In both my normal rec709 example and your linear rec709 example all is valid as long as you keep consistency in whatever you transform in and out of.
So Arri Wide Gamut LogC EI800 to ACEScg, not just Arri LogC curve because otherwise you assume the colorspace of your footage is already ACEScg if you go from that back to a target transform that does have a colorspace included.

Hope that makes sense.

1 Like

fixed the link. OH so you mean I should just be consistent and pick the same Arri profile. got it, it was by mistake if it wasn’t consistent. where are these screenshots coming from so nice and titled?

Ah no worries :slight_smile:
The grab is from the gallery function in FX Console.
Can highly recommend the plugin if you aren’t using it!

1 Like

of course I am using it! haven’t noticed the titles :slight_smile: thanks for all the help, you will get credit in the tutorial for this. not too much Aces tutorials out there. this is my channel BTW. tutorial every year! Ae Blues - YouTube

1 Like

I believe that using Input - ARRI - Curve - V3 LogC (EI800) will in fact assume that the footage has the primaries of the reference space (ACES2065-1) so AP0, not AP1.

So applying an OCIO colour space conversion from Input - ARRI - Curve - V3 LogC (EI800) to ACEScg will linearise using the EI800 LogC curve, and then apply an AP0 to AP1 matrix.

Thanks for correcting me there!