Aces in Katana

Hi,

I am trying to get parity between a Maya Arnold render and a 3delight katana render.

With both pieces of software I have setup the aces 1.2 ocio colour management (In maya via the colour management preferences), in katana this seems to be automatically setup when you set the OCIO environment variable, which is set to the aces config files.

Here is a comparison render below of the katana render.

There are two curbs (same model) in the image, they use only an albedo map. The one on screen right uses a jpg map (color space on file node is set to Utility Srgb Texture) and the one on the left is a exr map which the colour space is set to linear.

The curb on the right, matches the maya render exactly (maya is also set to Utility Srgb Texture). The one one the left doesn’t (slight red tint to it). In maya the linear texture is set to utility linear srgb colour space, but I don’t see this option in katana with a 3delight texture node.

Is there something I need to do in the ocio config file, in order to get this option in Katana? Alternatively there is an “ocio rules” option for the colour space on the texture node, which the documentation states, will be determined by the rules in the config file.

How do I know what the rules are currently set to in the config file? I searched for “rule” but got no results.

Any help would be much appreciated

Jim

Hi Jim,

Can’t give you a direct answer but this is what Redshift’s ocio v2 config looks like.

Maybe that helps.

Hello,
Your issue is on the 3delight side, which might miss some options in Katana.
My 2cents is that the colorspace option “linear” is not a colorspace defined in the ACES config but a supported option by 3Delight (probably default config). Which is probably similar to “raw” which mean there is just no conversion, hence why your sRGB source doesn’t looks correct.
Cheers.
Liam.

@Shebbe Thanks, I guess my question is, can I setup a similar type rule system in the base aces config file (the one which you download from github)

Not sure if you can write the same file rules in ociov1 maybe someone else can confirm.

This might be the case.
What options do you see in the 3Delight when Katana is configured to use ACES?

What you could check is perhaps convert your texture to ACEScg first and choose that as input instead of linear srgb. If the rest of Katana does work with the ACES config it’s working space should also be ACEScg and thus produce the same result if I’m not mistaken.
@MrLixm made a very nice tool to convert images.

1 Like

Hi,

These are the options listed when the OCIO env variable is set.

I also thought about doing what you suggest, but then realize there is no ACEScg colourspace option on the texture node.

For reference, these are the “default” colour spaces available, when not reading in the ocio config file.

image

and my monitor (render viewer) is set to ACEScg

image

What OCIO config are you using, I don’t remember seeing Input - Generic - sRGB - texture on the official ACES configs ? (unless I have miss some new versions)
Looks weird to have only these options.

I am using v1.2 from here

Alright my bad Input - Generic - sRGB - texture exists, I was just not used to see it.
It’ still weird that you have only a dozens of colourspace options while you should have the hundreds one defined in the config.

That’s so strange that only a few of the inputs are allowed. Seems mostly based on the roles list. I downloaded a trial version to check it myself and found that you can add extra roles to the config to make them show up in the input slot.
If you add this line to the list it might just work. You can give it any name you want as long as you reference to the true colorspace name Utility - Linear - sRGB.

Hope that helps!

Succuess! That worked a treat, now they match :slight_smile:

Thanks for your help!

1 Like