ACES slog2/3 to ACEScg workflow

Hello all!

Ive recently dived deep into the world of ACES at home on my personal computer (I use it at work, have for about 4 years now) and would love to find out the workflow to streamline my comps at home

My question is, regarding Nuke, what is the correct way to bring in the footage and convert to a ACES colourspace?

I’m shooting on a Sony a6300 with slog2 or slog3, if I bring this in and select within the colourspace of the read node: Input - Sony - sLog2/sLog3. Then write this out into ACEScg exr sequence

Bring that back into Nuke which now reads as ACEScg, this is the workflow to my understanding as im putting the footage I shot into the right colourspace to then be rendered out as ACEScg

I assume this is a correct way of doing it as I’ve seen people put it in the correct colorspace (within the read) and then add a OCIOtransform which to my understading adds double conversion. If i were to put the plate in raw then I’d use the OCIOcolorspace to change it and write that out

Heres a link with a timestamp to the bit on about:

Look forward to hearing from you!

Hello @harrikeagan and welcome to ACEScentral !

I do believe you workflow is correct :

  • Setting the Color Management Settings in Properties
  • Setting the IDT correctly on your read node

These two steps should be enough to work in ACEScg. In the video you sent, this person is indeed adding a double transform on the texture.

Hope it helps,


Hi @ChrisBrejon

Great thank you for the response! It’s humbling to know my workflow is correct and I’m happy to join the ACES world!

All the best


I just want to add that it might be helpful to get into the habit of adding a colorspace tag to the filename of the converted camera footage, like Clipname_acescg.####.exr, as the default exr format in ACES would be ACES (AP-0) not ACEScg (AP-1) and therefore the filename Clipname_aces.####.exr.

Tools like Flame/Maya/AffinityPhoto etc. can read his tags automatically and in Resolve your are reminded to change the IDT to ACEScg because Resolve expects ACES.



1 Like

That video is worryingly full of mistakes. He double converts. He sets the “ACES compliant” check-box which is tagging the EXR as AP0, when it is in fact AP1. He “shows” that the EXR and the original are the same by clicking back and forth between two nodes, which has no effect on the viewer in Nuke.

At that point I stopped watching. There are probably other errors.

Should we let him know on the youtube comments ? Might be worth it… Fortunately there are “only” 331 views…

1 Like