ACEScg doesn't match in AfterFX

Hello guys, i’ve some issues in general using ACEScg. Main issue is that i can’t match the 3D Software look in the After Effects.

Here’s some comparison images in this random test scene.
I’ve played with alot of settings in the AAE and did some variations for the .exr render it basically never matches.

Current temp solution is simply to save the renders to jpg or png out of V-Ray and it’s pretty much the same looking.

Guides followed:

  • some online read.


I think i’ve found the closest look by disabling sRGB in V-Ray ( i think while using OCIO that’s correct to disable sRGB which makes the ACEScg OCIO look darker and more saturated than default sRGB which i assume it’s the correct way the aces should look like ).

Then i’ve exported the .exr with OCIO profile disabled ( basically default render without ACES only that the poster and HDRI was converted to ACEScg which barely makes a difference anyway ).

In AAE i’ve disabled “Linearize Working Space” and used my monitors profile file instead of the “ACEScg” profile, then i aplied OpenColorIO plugin and set to In/Out: ACEScg and BOOM i have exact same looking image…

However, when i start changing exposure etc it doesn’t match the Vray’s profile.

Hello Exaco and welcome to ACEScentral !

I have tried to understand a best as I could your questions. I assume you are using V-Ray with Maya.

This probably because those jpg and png have the ODT burnt in. When your exr are probably ACEScg (linear).

I am not sure where you disabled sRGB (probably in the render view ?) and I am not a v-ray user myself. But I guess what you are describing is correct. Switching from plain sRGB to sRGB (ACES) will make your render darker because of tone mapping. Looking at the examples you provided, it definitely looks like a sRGB transfer function was applied on top of the sRGB ACES ODT. That’s one issue less I guess !

This part confuses me. If you are using an OCIO config to work with ACES and make the IDTs properly work, we should probably not disable it during the export process.

I have used the OCIO plugin for Photoshop once (like two years ago) and from what I can recall, using this plugin made me work in display-referred rather than scene-referred. This may be the issue in your case. At least I remember something similar in photoshop using the OCIO plugin.

Is using Nuke an option for you ? Nuke is much more fit to work with ACES. Even Fusion would do the trick. Nuke is free if you stick to Full HD resolutions for non-commercial work. And Fusion is free and comes with Resolve if I’m correct.

Hope this helps a bit,


1 Like

Thank you for your answer, i’ve played a bit further and yeah seems that in these examples i’ve had sRGB on top of ACES, here’s a test with Nuke attached, what bothers me here is that it seems too easy, in nuke colorspace i’ve set to ACES, but also it makes no difference pretty much which is odd to me.

Yes it does seem a bit too easy. :wink: I think what’s happening here is that you saved an exr with the sRGB (ACES) embedded/burnt in.

Once again I am no V-Ray user but it looks like the ‘Save in image’ option actually burns the View Transform in (sRGB ACES in your case). So by loading the exr as sRGB, it seems to match ! But by doing that you just went to scene-referred to display-referred which is not recommended if you plan to do some grading in Nuke.

Could you try disabling the ‘Save in image’ option when you save your render or set the View Transform to ‘Raw’ to get a proper ACEScg (linear) exr ?

Then you will need in Nuke to load it properly by setting ACES in the color management tab.

Let me know how this goes.
Thanks !

1 Like

Sorry for some delay, i’m playing around with it now, so i’ve tried to save the .exr without any OCIO applied, once i import it into nuke it’s by default matching without any OCIO convert nodes.

Apparently in the example above the Nuke wasn’t yet set to the ACES ( i had to start new project ), so if i import with burnt-in ACES OCIO i can’t get it matching, so i guess it explains most of my issues.

Cool. I did my best to help even if I am no V-Ray/AE user. I hope I was able to shed some light on this.But it looks like you were able to make it work on your own. Cool ! :wink: All the best, Chris

1 Like

Thanks, also seems like i have another issue, don’t really know how to export it for Web from Nuke ( or export from Nuke to PS/AAE/Lightroom etc ).

Also this method doesn’t work for AAE ( won’t work with Photoshop then too ).

An Idiot’s Guide to ACES:
“Before writing final images to disk, use the OCIOFileTransform node to convert your comp into the appropriate delivery color space. See the “Fusion” section above for hints on what color space you might want to write to.”


Set the write node in Nuke with the correct color space : output - sRGB or output - Rec.709. No need to use an OCIOFileTransform in this case. You’ll be able to write a jpg or a png with the ACES ODT baked in which is I suppose what you are trying to achieve. Let me know how this goes, Chris

1 Like

Thanks again!

Also i’ve found a solution for importing ACEScg which is:
Import non-burnt in exr -> enable preserve rgb > set LUT to None -> Apply OCIO ( ACEScg - ACEScg )

1 Like

Sounds about right ! I know how ACES/OCIO can be unsettling at first. But you won’t regret it, there is no going back after that ! Awesome man ! Chris

1 Like

I’ll should probably take your screenshots from this conversation and do a small tutorial for After effects. I guess it could help many artists. Thanks for contributing !