Different colors in Nuke and Resolve

So I am using Windows 10, Resolve 16 and Nuke 12. My screen is hardware calibrated to rec709.
No matter what I try colors between the two programs don’t match, Resolve being always slightly brighter, especially in the highlights.

Here a screenshot of my Nuke Setup:


Here one of my Resolve project settings:

And here one of the two pictures next to each other:

There definetely is that sliht difference.
I tried different IDTs and always have the same result.

I appreciate any advice.

Moreover, I have noticed that my whites behave general a bit weird (at leat to my knowledge) in Nuke.
Let’s say I put a constant node with a value of 1. It will appear slightly greyish and even the built in waveforms in Nuke will please the brightness at around 80. Is that supposed to be like that? And the Alpha channel is not affected by the way, only RGB.

So, I am just starting out with Aces and just cannot get over the initial barriers. I appreciate any help!

I’ve also tried different file formats. There’s always that slightest different. Also the tint is slightly off by by the way.

Hello @Olibaba and welcome to acescentral !

It seems that you are not using the same ACES version both in Nuke and resolve. Could you try using ACES 1.1 in both ?

Yes, it is completely normal that a white constant of value scene-referred (1,1,1) displays at approximatively at (0.83,0.83,0.83) through the Rec.709 (ODT). This is because of the tonemapping.


That shouldn’t be it. The Rec.709 transforms didn’t change between 1.0.3 and 1.1.

@Olibaba What I notice is that it seems you’re using sRGB as your viewing transform in OCIO but in your settings in Resolve you’re using Rec. 709. These transforms are not equivalent. The primaries are the same but the transfer function is not. Try setting Nuke to Rec 709 instead of sRGB.

EDIT: Actually your viewer does seem set to Rec. 709 but the monitor isn’t? I’m not sure what difference these things make but i bet some difference between Rec. 709 and sRGB is causing what you’re seeing. Someone better with OCIO should be able to notice it.

Thanks @sdyer The Log Shaper did change between 1.0.3 and 1.1, right ? Could this have an impact ?


Hey @Olibaba

Could it be that one of the two is reading the data as full and the other as video levels?
If I do a quick test here with Alexa log and force the read in Resolve to Full I get a similar issue as yours. (ACES 1.0.3 Resolve, ACES 1.2 Nuke) both set to view sRGB.
They are exactly the same otherwise.

Hey People, thanks for the ansers!
Sorry, my screenshots were misleading. While testing I made sure the Aces Version is the same, but I took one screenshot before switching in both programs and one after. It didn’t make any difference.

I also tried every combination of full and video data levels with the mxf file and they never matched completely.

Also, this even happens with simple srgb jpgs or linearly rendered exrs (havent tested rendering from 3d in aces). So I think, the fileformats and their implicacies don’t matter.

@ChrisBrejon I have informed myself better about ACES and can now appreciate that my whites are not at 1 anymore =)

@sdyer I have tried already to switch the monitor knob in the color tab from srgb to rec709 but it doesn’t make any difference in the color display

There more I look at it the less I’m sure what’s stronger: the difference in tint or luminance. Resolve renders slightly greener and brighter, nuke is more towards a magenta/warm tone and is slightly darker.

I guess I can ignore the issue (in the end, the variation of screens that this project will be seen on is mugh bigger than this small shift) but I would love to feel the satisfaction of solving this mistery.

edit: One more question: I’ve seen in a tutorial that the OCIO profiles can be set up in the environment of the OS. Is this needed? I guess the programs bring their own profiles, but I thought I’d ask just to make sure.

edit no2: another example: Mantra exr rendered in linear color space - set up accordingly in both programs. Look at the edges of the fire.

Just to really rule out everything…

What do you see when comparing Nuke to loading the clip in Resolve Fusion page and using ACES with the OCIO nodes instead? So leaving project management at ACEScct but transform the footage through Fusion page. Resolve assumes FusionClips to be ACEScg I think when being in ACES management. So you only need to go from Source to ACEScg inside Fusion.
What does the timeline/colorpage show then? Or maybe even try viewing the ODT inside Fusion page and compare.

Another thing to try would be to not manage Resolve but leave it at ‘default’ Davinci YRGB and manage color through the nodes and see what that gives. Both the edit timeline and the colorpage have ACES transforms.

All I’m thinking is that maybe the IDT you use in resolve is different from the OCIO one. But seeing you have the same issue with other files I’m not really sure what it could be. Maybe try different versions of Resolve to also rule that out.

Do you get the same issues on a “regular” sRGB monitor?

Maybe if it’s okay you could share that fire exr file so I could have a closer look into it?

The very last thing I can mention is I once had a color shift issue with some Alexa ProRes files going into Nuke and back out. We were able to fix it by re-rendering the ProRes files through AFX (no management) and checkboxing PerserveRGB… this fixed the colorshift in Nuke but we didn’t have any big luminance differences like you showed in your first post though…

This is only useful if you want OCIO supported applications to automatically detect your custom config so you don’t have to manually navigate to the folder each time. It doesn’t do anything else management wise.

Hope you can work it out!

1 Like

@Shebbe I am not very familiar with fusion so I will have to figure out how to do that. I just tried out the aces node but I get a completely different result.
Edit: I also tried the OCIO color space node but the results are also a bit weird. I cannot find where I set the viewer LUT.

I would be happy to share the exr but I couldn’t find a way to share it in this forum. EXRs cannot be uploaded here and a link is also not allowed. Is there a personal message function?

The behavior is the same on my other screen which is a regular srgb screen.
I will install 17 after a doing a quick backup.

Ah, sorry. You can use SHIFT + SPACE to add a node in Fusion. And you don’t need to set up a view LUT. You can also just add an OCIO node after the MediaOUT node for the ODT so it’s not considered when viewing the clip on the Edit Page.

As for the file, maybe a WeTransfer link, or Dropbox or Google Drive?

Problem solved !!!

Yay =)

After updating to Resolve 17, the EXRs look the same now, which is great. With the mxf-file, the tint is gone, but there is still a slight gamma difference, especially in the highlights. I would attribute that to the fileformat. Maybe the programs are decoding it slightly different. It’s a shame. Maybe I will avoid the format, but so far, it seemed the best compromise between disk space and performance, considering I am filming with a Lumix s1 in 10bt 422 h264.

I trusted Resolve so much that I wouldn’t have though that an update was all that’s needed.

Anyways thanks a lot people!

Ah great to hear! :slight_smile:
It’s always a good thing to hold off on updating software but so far I’ve heared lots of good things from people using 17.

H264 isn’t a great codec to work in. If you have the extra space I’d consider converting it to something like DNxHR or ProRes to make it a lot less heavy processing wise. Even better would be to capture in such a format with an external recorder if that S1 is able to give a clean feed at the same depth and chroma sampling or higher.

The .mxf was DNxHR encoded.
ProRes would mean another step in between, as Resolve cannot export prores on Windows, that I wanted to avoid. I’m trying to keep my pipeline as simple as possible.
I’m thinking to get a recorder soon.

1 Like

glad you found a solution ! well done guys ! :wink:

ACES has never been the only solution for “filmic-like highlight compression tone-mapping”. You are able to do it without ACES, using different solutions/methods. It is important to understand that ACES is a dedicated color encoding system and not a “look” although it is known for having a “pleasing look” (up until you see the " artifact" caused by the known flaws of ACES).

If you are referring to Resolve “color-space aware working space”, in theory, you should work with a gamut as wide as your footage. If you are working with wide gamut footage but with Rec.709/sRGB color wheels, you are restricting the tools.
Go to the project settings > change from a small to a wide gamut > select, for instance, the new color warpper tool > when doing the change in the preferences, hold ALT key and press save, you will see the difference it makes in the color-tools, without opening/closing back and forth the project settings window.

In theory, it should not.

Some programs ship with a pre-built ACES (Nuke and Resolve for instance). Otherwise, it is recommended to set an OCIO environment variable.

Be aware that “linear” is not a color space.
A color space is, shortly explained, is composed of 3 components:

  • gamut (specified by the primaries chromaticity coordinates),
  • a white point,
  • a transfer function.

ACEScg (output of a render from a given RGB renderer) can be translated as “linear-ACEScg”, and outside of an ACES based environment, by default, as “linear-sRGB”. Linear being the transfer function (what you commonly know as “gamma” 1.0) and the latter being the gamut you are working with.

Option 1: You set a (or two) OCIO node(s) with the ACES config file loaded and the input-ouput (ACEScg to ACES.sRGB ODT I would assume).
Option 2: You set OCIO on the viewer (but it does not get saved if you output the file from Fusion). To do so: the viewer option > Select OCIO > Edit > setup everything > Enable it by clicking on the square grid icon itself.

How heavy is the file? An EXR can weight as much as a JPG file: if you have no AOVs and use DWA compression, for instance. Also, ensure to not export 32-bpc EXR for a beauty render, as it is overkill. 16 half float is recommended for beauty and non-data AOVs/EXRs.

I would advise to not trust software. Double-check as much as possible, if unsure yourself. Resolve still has some improvements to do in regard to ACES and color management (ACES itself too while we are here).

1 Like