Nuke/Flame round trip

Hi all,
long time listener, first time caller :slight_smile:
I have recently encountered a conundrum when transferring files between Nuke and Flame. Here’s the trip:
Retime in Nuke > cleanup in Flame > back to Nuke for more comp
When I tick “write ACES compliant EXR” in Nuke, the files coming back from Flame have a slightly different grade. The image seems more saturated and contrast-y. Looking through the color channels, the red seems crushed. (see example)
The problem is solved by unticking the ACES compliant option and setting the compression to none.
Any ideas why this is happening?

Hey @yoavdolev,

I remember seeing bits of this pop up in other posts like this one.
From what I can tell you can leave it off and output in ACES2065-1 via the normal color space dropdown menu and pick desired compression.
For ACES compliant files it has to be uncompressed however.

Also make sure that you are reading and exporting your EXRs correctly in both software. Saturation increase sounds like a color space mismatch.

The main thing to remember is that the “write ACES compliant EXR” check box only writes metadata saying “this EXR is ACES” (and forces uncompressed half-float). It does not actually convert the image data to ACES2065-1. So it is easy to accidentally write ACEScg data to an EXR, but flag it as being ACES2065-1. If Flame’s colour pipeline is then configured on the assumption that the image data is something it is not, this will naturally result in problems with the round trip.

Below is what you get by default, if you are not careful. This will produce an ACEScg EXR flagged as being ACES2065-1. The compression is greyed out, and although the greyed out value might suggest it is locked to Zip compression, this is not the case. The file will be uncompressed. I do prefer it when applications actually show the value that will be used in a greyed out option.

It is certainly perfectly possible to round-trip ACES EXRs unmodified between Flame and Nuke, and have the image look identical in both applications. I’ve done it numerous times. You just need to make sure you have correctly matching settings.

1 Like

Hi @nick and @Shebbe
Thanks for your reply!
Currently the output transform is set to scene_linear (we are working in ACEScg).
I was ticking the “write ACES compliant EXR”.
It seems that setting the compression to “none” has resolved my issue.
I will definitely investigate further.